Updating Firmware (3.74)

For support in English, ask for help at HENkaku on Discord.

Required Reading

The h-encore exploit is only compatible with the firmware versions 3.65 and above. As a result, lower firmware versions must update to the latest firmware to use the exploit.

What you need

  • An internet connection on your PS Vita (TV)

Instructions

  1. Navigate to System Update -> Update Using Wi-Fi
  2. Ensure the update message "Version 3.74" is displayed
    • If it doesn't, clear your Wi-Fi DNS settings and try again
  3. Follow the prompts to update your device to 3.74
    • When the process has completed, your device will reboot automatically

TIP

Continue to Installing h-encore