Updating Firmware (3.73)


For support in English, ask for help at HENkaku on Discord.
If you appreciate this guide, we accept Donations.


Required Reading

The h-encore exploit is only compatible with the firmware versions 3.65 and above. As a result, lower firmware versions must update to the latest firmware to use the exploit.

What you need

  • An internet connection on your PS Vita (TV)

Instructions

  1. Navigate to System Update -> Update Using Wi-Fi
  2. Follow the prompts to update your device to 3.73
    • When the process has completed, your device will reboot automatically

Continue to Installing h-encore